안녕 리눅스 Upgrade Guide

이 문서는 안녕 리눅스의 minor 버전 업그레이드에 대한 정보를 안내 합니다.

1. Minor version 업그레이드

기본적으로 안녕 리눅스의 minor version upgrade(예를 들어 3.1 에서 3.2로 업그레이드)는 간단하게 yum udpate 명령으로 진행 합니다. 특정 버전의 변경 사항이 기록 되지 않는 한, yum update 명령으로 간단히 업그레이드를 진행 할 수 있습니다.

2. 버전 별 주의 사항

2.1 3.2 Upgrade 전 주의 사항

안녕 리눅스 3.2 업그레이드시에, yum update 로 업그레이드를 하기 전 다음의 단계를 먼저 실행 한 후에 진행 하여야 합니다.

이 주의 사항은 3.0 또는 3.1 에서 yum update 명령을 이용하여 3.2 이상으로 업데이트 할 경우에 해당 합니다.

업그레이드 전에 다음의 명령을 먼저 실행 하십시오.

[root@host ~]$ yum update annyung-release rdma-core.x86_64

그리고, 업그레이드를 마친 이 후, rebooting 전에 grub.cfg 를 갱신해 주도록 합니다.

[root@host ~]$ grup2-mkconfig -o /boot/grub2/grub.cfg

안녕 리눅스 3.2 업데이트 시에, 알려진 버그로는 2가지가 있습니다.

  1. python module 관련 package에서 openssl 1.0.2 link 정보 때문에 openssl 1.0.1 이 설치 되어 있는 machine에서 의존성 에러 발생

    --> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: python2-cryptography-1.7.2-1.el7.x86_64
    --> Running transaction check
    ---> Package grub2-pc-modules.noarch 1:2.02-0.64.el7.centos will be installed
    ---> Package python2-cryptography.x86_64 0:1.7.2-1.el7 will be an update
    --> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: python2-cryptography-1.7.2-1.el7.x86_64
    --> Finished Dependency Resolution
    Error: Package: python2-cryptography-1.7.2-1.el7.x86_64 (base)
            Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
            Available: 1:openssl-libs-1.0.2k-8.el7.x86_64 (AN:base)
                libcrypto.so.10(OPENSSL_1.0.2)(64bit)
            Installed: 10:openssl-libs-1.0.1e-60.an3.1.x86_64 (@AnNyung-Base)
               ~libcrypto.so.10(OPENSSL_1.0.1)(64bit)
    

    이 문제는 안녕의 openssl이 CentOS의 openssl 보다 epoch 버전이 높아서 openssl 이 업그레이드 되지 않는 문제 때문 입니다. annyung-release package를 먼저 설치를 하면 이 문제를 해결해 줍니다.

    annyung-release 3.2 를 설치를 하면, cronjob 으로 설치 1분 후 openssl을 1.0.2k로 변경을 합니다. 이 작업은 annyung-release 를 설치하는 대신 openssl을 직접 downgrade 하는 방법이 있습니다만, 1.0.1e -> 1.0.2k 로의 변환이 upgrade가 아닌 downgrade 이기 때문에 annyung-release 에서 대신 처리를 해 주는 겁니다.

    [root@host ~]$ yum -y downgrade 'openssl*'
    

    명령으로 대신할 수 있는데, upgrade가 아닌 downgrade 인 이유는 안녕 리눅스의 openssl-1.0.1e 의 epoch가 CentOS의 openssl 보다 높기 때문에 yum이 안녕 리눅스의 openssl을 상위 버전으로 판단하기 때문 입니다.

  2. i686 관련 package 의존성 문제

    ---> Package rdma.noarch 0:7.3_4.7_rc2-6.el7_3 will be obsoleted
    ---> Package rdma-core.i686 0:13-7.el7 will be obsoleting
    --> Processing Dependency: libudev.so.1(LIBUDEV_183) for package: rdma-core-13-7.el7.i686
    --> Processing Dependency: libudev.so.1 for package: rdma-core-13-7.el7.i686
    --> Processing Dependency: libc.so.6(GLIBC_2.16) for package: rdma-core-13-7.el7.i686
    ---> Package rdma-core.x86_64 0:13-7.el7 will be obsoleting
    ...
    --> Finished Dependency Resolution
    Error:  Multilib version problems found. This often means that the root
        cause is something else and multilib version checking is just
        pointing out that there is a problem. Eg.:
    
          1. You have an upgrade for systemd-libs which is missing some
             dependency that another package requires. Yum is trying to
             solve this by installing an older version of systemd-libs of the
             different architecture. If you exclude the bad architecture
             yum will tell you what the root cause is (which package
             requires what). You can try redoing the upgrade with
             --exclude systemd-libs.otherarch ... this should give you an error
             message showing the root cause of the problem.
    
          2. You have multiple architectures of systemd-libs installed, but
             yum can only see an upgrade for one of those architectures.
             If you don't want/need both architectures anymore then you
             can remove the one with the missing update and everything
             will work.
    
          3. You have duplicate versions of systemd-libs installed already.
             You can use "yum check" to get yum show these errors.
    
        ...you can also use --setopt=protected_multilib=false to remove
        this checking, however this is almost never the correct thing to
        do as something else is very likely to go wrong (often causing
        much more problems).
    
        Protected multilib versions: systemd-libs-219-42.el7_4.1.i686 != 100:systemd-libs-219-42.an3.x86_64
    Error: Protected multilib versions: pam-1.1.8-18.el7.i686 != 1:pam-1.1.8-18.an3.x86_64
    

    안녕 리눅스는 기본적으로 32bit package를 설치 하지 못하도록 막고 있습니다. CentOS 7.3 까지 제공하는 rdma.noarch package의 경우 CentOS 7.4에서 rdma-core package로 변경 되면서 noarch package가 i686 과 x86_64 패키지로 변경이 되면서, 기본으로 i686 package로 전환하려는 경우 문제가 발생 합니다.

    그러므로, 업그레이드 전에 rdma package를 rdma-core.x86_64 package로 architecture를 지정해서 먼저 업데이트를 시킨 후에 업데이트를 진행 합니다.

results matching ""

    No results matching ""